# CVE-2018-1000189: CSRF vulnerability and missing permission checks in Jenkins AbsInt Astrée Plugin

> Attackers with read access can execute arbitrary commands on the Jenkins master via the Absint Astree Plugin.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-c9px-7j36-f35v

## What is CVE-2018-1000189?

CVE-2018-1000189 is a high-severity command injection vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A command execution vulnerability exists in Jenkins Absint Astree Plugin 1.0.5 and older in AstreeBuilder.java that allows attackers with Overall/Read access to execute a command on the Jenkins master.

## Which versions are affected by CVE-2018-1000189?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:absint-astree. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:absint-astree` | Maven | All versions | 1.0.7 |
| `org.jenkins-ci.plugins:absint-astree` | Maven | All versions | 1.0.7 |

Products: Jenkins Absint Astree.

## How do I fix CVE-2018-1000189?

Upgrade org.jenkins-ci.plugins:absint-astree to 1.0.7 or later.

## Is CVE-2018-1000189 being exploited?

There is no known exploitation of CVE-2018-1000189 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000189 and fix it if it is affected.

What it is: CVE-2018-1000189 is a high-severity command injection vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000189 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:absint-astree (Maven): affected all versions; fixed in 1.0.7
- org.jenkins-ci.plugins:absint-astree (Maven): affected all versions; fixed in 1.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000189/ (Markdown: https://insights.sbomify.com/CVE-2018-1000189/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000189
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000189
- OSV: https://osv.dev/vulnerability/CVE-2018-1000189

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000189/
Summaries are generated and may contain mistakes; the official description above is the record.
