{"answers":{"affected":"2 open source packages ship an affected version, including com.synopsys.integration:synopsys-detect. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000191 in the wild and no public exploit code.","fix":"Upgrade com.synopsys.integration:synopsys-detect to 1.4.1 or later.","what":"CVE-2018-1000191 is a medium-severity vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000191 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000191 is a medium-severity vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.synopsys.integration:synopsys-detect (Maven): affected all versions; fixed in 1.4.1\n- com.synopsys.integration:synopsys-detect (Maven): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000191/ (Markdown: https://insights.sbomify.com/CVE-2018-1000191/index.md)","id":"CVE-2018-1000191","markdown":"https://insights.sbomify.com/CVE-2018-1000191/index.md","name":"CVE-2018-1000191","record":{"aliases":["GHSA-6w3h-vq7m-v3qf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Black Duck Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can capture stored Jenkins credentials by connecting to an attacker-controlled URL via the Black Duck Detect plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"synopsys_detect","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A exposure of sensitive information vulnerability exists in Jenkins Black Duck Detect Plugin 1.4.0 and older in DetectPostBuildStepDescriptor.java that allows attackers with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Black Duck Detect Plugin information exposure vulnerability","id":"CVE-2018-1000191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Jenkins","id":"CVE-2018-1000192"},"packages":[{"ecosystem":"Maven","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"com.synopsys.integration:synopsys-detect","purl":null,"source":"GHSA-6w3h-vq7m-v3qf"},{"ecosystem":"Maven","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"com.synopsys.integration:synopsys-detect","purl":"pkg:maven/com.synopsys.integration/synopsys-detect","source":"GHSA-6w3h-vq7m-v3qf"}],"prev":{"headline":"Exposure of sensitive information vulnerability in Jenkins Black Duck Hub Plugin","id":"CVE-2018-1000190"},"products":["n/a"],"published":"2018-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers with read access can capture stored Jenkins credentials by connecting to an attacker-controlled URL via the Black Duck Detect plugin.","url":"https://insights.sbomify.com/CVE-2018-1000191/"}