CVE-2018-1000192 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

Medium 4.3 Published Updated

Users with read access can enumerate installed plugins, exposing system configuration details to potential attackers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000192?

CVE-2018-1000192 is a medium-severity vulnerability in Jenkins Jenkins, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A information exposure vulnerability exists in Jenkins 2.120 and older, LTS 2.107.2 and older in AboutJenkins.java, ListPluginsCommand.java that allows users with Overall/Read access to enumerate all installed plugins.

Which versions are affected by CVE-2018-1000192?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.107.3
org.jenkins-ci.main:jenkins-core MavenAll versions2.107.3
org.jenkins-ci.main:jenkins-core MavenFrom 2.1082.121
org.jenkins-ci.main:jenkins-core MavenFrom 2.1082.121

Products include Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite.

How do I fix CVE-2018-1000192?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.107.3 or 2.121.

Is CVE-2018-1000192 being exploited?

There is no known exploitation of CVE-2018-1000192 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-2w4x-rxp7-grg7.

Is CVE-2018-1000192 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free