# CVE-2018-1000197: Jenkins Black Duck Hub Plugin allowed any user with Overall/Read to read and write its configuration

> Users with Overall/Read permission can read and write Black Duck Hub plugin configuration due to improper authorization checks.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-crvq-mw2w-4cfx

## What is CVE-2018-1000197?

CVE-2018-1000197 is a high-severity missing authorization vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins Black Duck Hub Plugin 3.0.3 and older in PostBuildScanDescriptor.java that allows users with Overall/Read permission to read and write the Black Duck Hub plugin configuration.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1000197?

2 open source packages ship an affected version, including com.blackducksoftware.integration:blackduck-hub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.blackducksoftware.integration:blackduck-hub` | Maven | All versions | 3.1.0 |
| `com.blackducksoftware.integration:blackduck-hub` | Maven | All versions | 3.1.0 |

Products: Jenkins Black Duck Hub.

## How do I fix CVE-2018-1000197?

Upgrade com.blackducksoftware.integration:blackduck-hub to 3.1.0 or later.

## Is CVE-2018-1000197 being exploited?

There is no known exploitation of CVE-2018-1000197 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000190](https://insights.sbomify.com/CVE-2018-1000190/): Exposure of sensitive information vulnerability in Jenkins Black Duck Hub Plugin (medium 6.5)
- [CVE-2018-1000198](https://insights.sbomify.com/CVE-2018-1000198/): XML External Entity processing vulnerability in Jenkins Black Duck Hub Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000197 and fix it if it is affected.

What it is: CVE-2018-1000197 is a high-severity missing authorization vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000197 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.blackducksoftware.integration:blackduck-hub (Maven): affected all versions; fixed in 3.1.0
- com.blackducksoftware.integration:blackduck-hub (Maven): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000197/ (Markdown: https://insights.sbomify.com/CVE-2018-1000197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000197
- OSV: https://osv.dev/vulnerability/CVE-2018-1000197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000197/
Summaries are generated and may contain mistakes; the official description above is the record.
