{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:groovy-postbuild. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000202 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:groovy-postbuild to 2.4 or later.","what":"CVE-2018-1000202 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000202 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000202 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000202 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:groovy-postbuild (Maven): affected all versions; fixed in 2.4\n- org.jvnet.hudson.plugins:groovy-postbuild (Maven): affected all versions; fixed in 2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000202/ (Markdown: https://insights.sbomify.com/CVE-2018-1000202/index.md)","id":"CVE-2018-1000202","markdown":"https://insights.sbomify.com/CVE-2018-1000202/index.md","name":"CVE-2018-1000202","record":{"aliases":["GHSA-38ch-x695-m794"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Groovy Postbuild Plugin","requires_auth":"low_privilege","summary":"Attackers controlling build badges can inject JavaScript executed in other users' browsers via the Jenkins Groovy Postbuild Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"groovy_postbuild","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A persisted cross-site scripting vulnerability exists in Jenkins Groovy Postbuild Plugin 2.3.1 and older in various Jelly files that allows attackers able to control build badge content to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Groovy Postbuild Plugin vulnerable to Cross-site Scripting","id":"CVE-2018-1000202","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Business logic in n/a","id":"CVE-2018-1000203"},"packages":[{"ecosystem":"Maven","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:groovy-postbuild","purl":null,"source":"GHSA-38ch-x695-m794"},{"ecosystem":"Maven","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:groovy-postbuild","purl":"pkg:maven/org.jvnet.hudson.plugins/groovy-postbuild","source":"GHSA-38ch-x695-m794"}],"prev":{"headline":"Ruby-ffi has a DLL loading issue","id":"CVE-2018-1000201"},"products":["n/a"],"published":"2018-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers controlling build badges can inject JavaScript executed in other users' browsers via the Jenkins Groovy Postbuild Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000202/"}