CVE-2018-1000207 MODX Revolution Incorrect Access Control vulnerability

High 7.2 Published Updated

Attackers can upload arbitrary files with custom names and content via web requests due to improper access control in MODX Revolution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000207?

CVE-2018-1000207 is a high-severity vulnerability in n/a, published on 13 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

MODX Revolution version <=2.6.4 contains a Incorrect Access Control vulnerability in Filtering user parameters before passing them into phpthumb class that can result in Creating file with custom a filename and content. This attack appear to be exploitable via Web request. This vulnerability appears to have been fixed in commit 06bc94257408f6a575de20ddb955aca505ef6e68.

Weakness: CWE-732

Which versions are affected by CVE-2018-1000207?

2 open source packages ship an affected version, including modx/revolution. It affects 1 product.

PackageAffectedFixed in
modx/revolution PackagistAll versions2.7.0
modx/revolution PackagistAll versions2.7.0

Products include Modx Modx Revolution.

How do I fix CVE-2018-1000207?

Upgrade modx/revolution to 2.7.0 or later.

Is CVE-2018-1000207 being exploited?

There is no known exploitation of CVE-2018-1000207 in the wild and no public exploit code.

Sources

Also known as GHSA-m899-6mh4-mpc5.

Is CVE-2018-1000207 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free