{"answers":{"affected":"2 open source packages ship an affected version, including doorkeeper. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000211 in the wild and no public exploit code.","fix":"Upgrade doorkeeper to 4.4.0 or later.","what":"CVE-2018-1000211 is a high-severity missing authorization vulnerability in n/a, published on 13 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000211 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000211 is a high-severity missing authorization vulnerability in n/a, published on 13 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000211 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- doorkeeper (RubyGems): affected from 4.2.0; fixed in 4.4.0\n- doorkeeper (RubyGems): affected from 4.2.0; fixed in 4.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000211/ (Markdown: https://insights.sbomify.com/CVE-2018-1000211/index.md)","id":"CVE-2018-1000211","markdown":"https://insights.sbomify.com/CVE-2018-1000211/index.md","name":"CVE-2018-1000211","record":{"aliases":["DEBIAN-CVE-2018-1000211","GHSA-694m-jhr9-pf77","UBUNTU-CVE-2018-1000211"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth library","requires_auth":"none","summary":"Attackers can retain valid access tokens for public OAuth apps because revocation fails, allowing unauthorized data access until expiry.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"doorkeeper","vendor":"doorkeeper_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can result in Access tokens are not revoked for public OAuth apps, leaking access until expiry.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Doorkeeper subject to Incorrect Permission Assignment","id":"CVE-2018-1000211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-1000215"},"packages":[{"ecosystem":"RubyGems","fixed":["4.4.0"],"introduced":["4.2.0"],"last_affected":[],"package":"doorkeeper","purl":null,"source":"GHSA-694m-jhr9-pf77"},{"ecosystem":"RubyGems","fixed":["4.4.0"],"introduced":["4.2.0"],"last_affected":[],"package":"doorkeeper","purl":"pkg:gem/doorkeeper","source":"GHSA-694m-jhr9-pf77"}],"prev":{"headline":"High severity vulnerability that affects YamlDotNet and YamlDotNet.Signed","id":"CVE-2018-1000210"},"products":["n/a"],"published":"2018-07-13","related":[{"cvss_score":9.1,"headline":"Doorkeeper is vulnerable to replay attacks","id":"CVE-2016-6582","kev_date_added":null,"published":"2017-01-23"},{"cvss_score":7.5,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper","id":"CVE-2020-10187","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":6.8,"headline":"Doorkeeper vulnerable to Cross-site Request Forgery","id":"CVE-2014-8144","kev_date_added":null,"published":"2014-12-31"},{"cvss_score":6.1,"headline":"Doorkeeper is vulnerable to stored XSS and code execution","id":"CVE-2018-1000088","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":4.2,"headline":"Doorkeeper Improper Authentication vulnerability","id":"CVE-2023-34246","kev_date_added":null,"published":"2023-06-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can retain valid access tokens for public OAuth apps because revocation fails, allowing unauthorized data access until expiry.","url":"https://insights.sbomify.com/CVE-2018-1000211/"}