# CVE-2018-1000211: Doorkeeper subject to Incorrect Permission Assignment

> Attackers can retain valid access tokens for public OAuth apps because revocation fails, allowing unauthorized data access until expiry.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1000211, GHSA-694m-jhr9-pf77, UBUNTU-CVE-2018-1000211

## What is CVE-2018-1000211?

CVE-2018-1000211 is a high-severity missing authorization vulnerability in n/a, published on 13 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can result in Access tokens are not revoked for public OAuth apps, leaking access until expiry.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-1000211?

2 open source packages ship an affected version, including doorkeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `doorkeeper` | RubyGems | From 4.2.0 | 4.4.0 |
| `doorkeeper` | RubyGems | From 4.2.0 | 4.4.0 |

Products: Doorkeeper Project Doorkeeper.

## How do I fix CVE-2018-1000211?

Upgrade doorkeeper to 4.4.0 or later.

## Is CVE-2018-1000211 being exploited?

There is no known exploitation of CVE-2018-1000211 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-6582](https://insights.sbomify.com/CVE-2016-6582/): Doorkeeper is vulnerable to replay attacks (critical 9.1)
- [CVE-2020-10187](https://insights.sbomify.com/CVE-2020-10187/): Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper (high 7.5)
- [CVE-2014-8144](https://insights.sbomify.com/CVE-2014-8144/): Doorkeeper vulnerable to Cross-site Request Forgery (medium 6.8)
- [CVE-2018-1000088](https://insights.sbomify.com/CVE-2018-1000088/): Doorkeeper is vulnerable to stored XSS and code execution (medium 6.1)
- [CVE-2023-34246](https://insights.sbomify.com/CVE-2023-34246/): Doorkeeper Improper Authentication vulnerability (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000211 and fix it if it is affected.

What it is: CVE-2018-1000211 is a high-severity missing authorization vulnerability in n/a, published on 13 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000211 in the wild and no public exploit code.

Affected packages and fixed versions:
- doorkeeper (RubyGems): affected from 4.2.0; fixed in 4.4.0
- doorkeeper (RubyGems): affected from 4.2.0; fixed in 4.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000211/ (Markdown: https://insights.sbomify.com/CVE-2018-1000211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000211
- OSV: https://osv.dev/vulnerability/CVE-2018-1000211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000211/
Summaries are generated and may contain mistakes; the official description above is the record.
