# CVE-2018-1000215: Denial of service in n/a

> An attacker can cause a denial of service in applications using the cJSON library by triggering a memory leak during data printing under low memory conditions.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-41919, DEBIAN-CVE-2018-1000215, GHSA-9xc3-9g76-hcvx

## What is CVE-2018-1000215?

CVE-2018-1000215 is a high-severity denial of service vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dave Gamble cJSON version 1.7.6 and earlier contains a CWE-772 vulnerability in cJSON library that can result in Denial of Service (DoS). This attack appear to be exploitable via If the attacker can force the data to be printed and the system is in low memory it can force a leak of memory. This vulnerability appears to have been fixed in 1.7.7.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2018-1000215?

It affects 1 product.


Products: Davegamble Cjson.

## How do I fix CVE-2018-1000215?

Upgrade to a fixed version.

## Is CVE-2018-1000215 being exploited?

There is no known exploitation of CVE-2018-1000215 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-57052](https://insights.sbomify.com/CVE-2025-57052/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-11834](https://insights.sbomify.com/CVE-2019-11834/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-11835](https://insights.sbomify.com/CVE-2019-11835/): Memory corruption in n/a (critical 9.8)
- [CVE-2016-10749](https://insights.sbomify.com/CVE-2016-10749/): Memory corruption in n/a (critical 9.8)
- [CVE-2018-1000217](https://insights.sbomify.com/CVE-2018-1000217/): Use after free in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000215 and fix it if it is affected.

What it is: CVE-2018-1000215 is a high-severity denial of service vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000215 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000215/ (Markdown: https://insights.sbomify.com/CVE-2018-1000215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000215
- OSV: https://osv.dev/vulnerability/CVE-2018-1000215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000215/
Summaries are generated and may contain mistakes; the official description above is the record.
