CVE-2018-1000216 Memory corruption in n/a

High 8.8 Published Updated

A double free vulnerability in the cJSON library allows attackers to cause crashes or execute arbitrary code by forcing the victim to print JSON data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-1000216?

CVE-2018-1000216 is a high-severity memory corruption vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Dave Gamble cJSON version 1.7.2 and earlier contains a CWE-415: Double Free vulnerability in cJSON library that can result in Possible crash or RCE. This attack appear to be exploitable via Attacker must be able to force victim to print JSON data, depending on how cJSON library is used this could be either local or over a network. This vulnerability appears to have been fixed in 1.7.3.

Weakness: CWE-415

Which versions are affected by CVE-2018-1000216?

It affects 1 product.

Products include Davegamble Cjson.

How do I fix CVE-2018-1000216?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2018-1000216 being exploited?

There is no known exploitation of CVE-2018-1000216 in the wild and no public exploit code.

Sources

Also known as AZL-41848, GHSA-3g82-r8f2-r5vq.

Is CVE-2018-1000216 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free