# CVE-2018-1000216: Memory corruption in n/a

> A double free vulnerability in the cJSON library allows attackers to cause crashes or execute arbitrary code by forcing the victim to print JSON data.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2018
- **Updated:** 17 Sep 2024
- **Also known as:** AZL-41848, GHSA-3g82-r8f2-r5vq

## What is CVE-2018-1000216?

CVE-2018-1000216 is a high-severity memory corruption vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dave Gamble cJSON version 1.7.2 and earlier contains a CWE-415: Double Free vulnerability in cJSON library that can result in Possible crash or RCE. This attack appear to be exploitable via Attacker must be able to force victim to print JSON data, depending on how cJSON library is used this could be either local or over a network. This vulnerability appears to have been fixed in 1.7.3.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2018-1000216?

It affects 1 product.


Products: Davegamble Cjson.

## How do I fix CVE-2018-1000216?

Upgrade to a fixed version.

## Is CVE-2018-1000216 being exploited?

There is no known exploitation of CVE-2018-1000216 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-57052](https://insights.sbomify.com/CVE-2025-57052/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-11834](https://insights.sbomify.com/CVE-2019-11834/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-11835](https://insights.sbomify.com/CVE-2019-11835/): Memory corruption in n/a (critical 9.8)
- [CVE-2016-10749](https://insights.sbomify.com/CVE-2016-10749/): Memory corruption in n/a (critical 9.8)
- [CVE-2018-1000217](https://insights.sbomify.com/CVE-2018-1000217/): Use after free in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000216 and fix it if it is affected.

What it is: CVE-2018-1000216 is a high-severity memory corruption vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000216 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000216/ (Markdown: https://insights.sbomify.com/CVE-2018-1000216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000216
- OSV: https://osv.dev/vulnerability/CVE-2018-1000216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000216/
Summaries are generated and may contain mistakes; the official description above is the record.
