CVE-2018-1000226 Cobbler Improper Validation of Security Tokens
Attackers can exploit improper security token validation in the XMLRPC API to escalate privileges, manipulate data, or harvest credentials.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1000226?
CVE-2018-1000226 is a critical missing authorization vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.
Weakness: CWE-732
Which versions are affected by CVE-2018-1000226?
3 open source packages ship an affected version, including cobbler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cobbler PyPI | All versions | 3.0.0 |
cobbler PyPI | All versions | 3.0.0 |
cobbler PyPI | All versions | 3.0.0 |
Products include Cobblerd Cobbler.
How do I fix CVE-2018-1000226?
Upgrade cobbler to 3.0.0 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2018-1000226 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000226 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in n/a
Sources
Also known as GHSA-f88q-22g8-frcg, PYSEC-2026-315, UBUNTU-CVE-2018-1000226.