{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000226 exists.","fix":"Upgrade cobbler to 3.0.0 or later.","what":"CVE-2018-1000226 is a critical missing authorization vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000226 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000226 is a critical missing authorization vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000226 exists.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 3.0.0\n- cobbler (PyPI): affected all versions; fixed in 3.0.0\n- cobbler (PyPI): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000226/ (Markdown: https://insights.sbomify.com/CVE-2018-1000226/index.md)","id":"CVE-2018-1000226","markdown":"https://insights.sbomify.com/CVE-2018-1000226/index.md","name":"CVE-2018-1000226","record":{"aliases":["GHSA-f88q-22g8-frcg","PYSEC-2026-315","UBUNTU-CVE-2018-1000226"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["privilege_escalation","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"none","summary":"Attackers can exploit improper security token validation in the XMLRPC API to escalate privileges, manipulate data, or harvest credentials.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cobbler","vendor":"cobblerd"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via \"network connectivity\". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2018/CVE-2018-1000226.yaml","stars":null,"title":"Cobbler - Authentication Bypass"}],"tier":"weaponised"},"has_fix":true,"headline":"Cobbler Improper Validation of Security Tokens","id":"CVE-2018-1000226","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-1000300"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-f88q-22g8-frcg"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-f88q-22g8-frcg"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-315"}],"prev":{"headline":"Cobbler XSS Vulnerability","id":"CVE-2018-1000225"},"products":["n/a"],"published":"2018-08-20","related":[{"cvss_score":8.8,"headline":"Cobbler Web Interface Lacks CSRF Protection","id":"CVE-2011-4952","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":7.8,"headline":"Privilege escalation in cobbler","id":"CVE-2011-4954","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":6.1,"headline":"Cobbler XSS Vulnerability","id":"CVE-2018-1000225","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":4,"headline":"Cobbler Path Traversal vulnerability","id":"CVE-2014-3225","kev_date_added":null,"published":"2014-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can exploit improper security token validation in the XMLRPC API to escalate privileges, manipulate data, or harvest credentials.","url":"https://insights.sbomify.com/CVE-2018-1000226/"}