# CVE-2018-1000226: Cobbler Improper Validation of Security Tokens

> Attackers can exploit improper security token validation in the XMLRPC API to escalate privileges, manipulate data, or harvest credentials.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f88q-22g8-frcg, PYSEC-2026-315, UBUNTU-CVE-2018-1000226

## What is CVE-2018-1000226?

CVE-2018-1000226 is a critical missing authorization vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-1000226?

3 open source packages ship an affected version, including cobbler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | All versions | 3.0.0 |
| `cobbler` | PyPI | All versions | 3.0.0 |
| `cobbler` | PyPI | All versions | 3.0.0 |

Products: Cobblerd Cobbler.

## How do I fix CVE-2018-1000226?

Upgrade cobbler to 3.0.0 or later.

## Is CVE-2018-1000226 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000226 exists.

Public exploit code:

- Cobbler - Authentication Bypass (nuclei): http/cves/2018/CVE-2018-1000226.yaml

## Other vulnerabilities in n/a

- [CVE-2011-4952](https://insights.sbomify.com/CVE-2011-4952/): Cobbler Web Interface Lacks CSRF Protection (high 8.8)
- [CVE-2011-4954](https://insights.sbomify.com/CVE-2011-4954/): Privilege escalation in cobbler (high 7.8)
- [CVE-2018-1000225](https://insights.sbomify.com/CVE-2018-1000225/): Cobbler XSS Vulnerability (medium 6.1)
- [CVE-2014-3225](https://insights.sbomify.com/CVE-2014-3225/): Cobbler Path Traversal vulnerability (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000226 and fix it if it is affected.

What it is: CVE-2018-1000226 is a critical missing authorization vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000226 exists.

Affected packages and fixed versions:
- cobbler (PyPI): affected all versions; fixed in 3.0.0
- cobbler (PyPI): affected all versions; fixed in 3.0.0
- cobbler (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000226/ (Markdown: https://insights.sbomify.com/CVE-2018-1000226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000226
- OSV: https://osv.dev/vulnerability/CVE-2018-1000226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000226/
Summaries are generated and may contain mistakes; the official description above is the record.
