CVE-2018-1000300 Memory corruption in n/a

Critical 9.8 Published Updated

Heap-based buffer overflow in curl allows attackers to cause denial of service or potentially execute code via long FTP server replies.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000300?

CVE-2018-1000300 is a critical memory corruption vulnerability in Canonical Ubuntu Linux, published on 24 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.

Weakness: CWE-787

Which versions are affected by CVE-2018-1000300?

It affects 2 products.

Products include Canonical Ubuntu Linux, Haxx Curl.

How do I fix CVE-2018-1000300?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2018-1000300 being exploited?

There is no known exploitation of CVE-2018-1000300 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2018-1000300, CLEANSTART-2026-MS57459, CURL-CVE-2018-1000300, DEBIAN-CVE-2018-1000300, GHSA-5vcr-2m3x-3m96, UBUNTU-CVE-2018-1000300.

Is CVE-2018-1000300 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free