CVE-2018-1000301 Memory corruption in n/a

Critical 9.1 Published Updated

A buffer over-read in curl's RTSP handling allows attackers to cause a denial of service by tricking the library into reading beyond heap boundaries.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000301?

CVE-2018-1000301 is a critical memory corruption vulnerability in Canonical Ubuntu Linux, published on 24 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

Weakness: CWE-125

Which versions are affected by CVE-2018-1000301?

It affects 9 products.

Linux distribution packages (16)
curl SUSE:Enterprise Storage 4All versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Desktop 12 SP3All versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server 11 SP4All versions7.37.0-70.30.1
curl-openssl1 SUSE:Linux Enterprise Server 11-SECURITYAll versions7.37.0-70.30.1
curl SUSE:Linux Enterprise Server 12 SP1-LTSSAll versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server 12 SP2-BCLAll versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server 12 SP2-LTSSAll versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server 12 SP3All versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server 12-LTSSAll versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server for SAP Applications 11 SP4All versions7.37.0-70.30.1
curl SUSE:Linux Enterprise Server for SAP Applications 12 SP1All versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server for SAP Applications 12 SP2All versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Server for SAP Applications 12 SP3All versions7.37.0-37.23.1
curl SUSE:Linux Enterprise Software Development Kit 11 SP4All versions7.37.0-70.30.1
curl SUSE:Linux Enterprise Software Development Kit 12 SP3All versions7.37.0-37.23.1
curl SUSE:OpenStack Cloud 7All versions7.37.0-37.23.1

Products include Canonical Ubuntu Linux, Debian Debian Linux, Haxx Curl, Oracle Communications Webrtc Session Controller, Oracle Enterprise Manager Ops Center, Oracle Peoplesoft Enterprise Peopletools and 3 more.

How do I fix CVE-2018-1000301?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2018-1000301 being exploited?

There is no known exploitation of CVE-2018-1000301 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2018-1000301, CLEANSTART-2026-VH87941, CURL-CVE-2018-1000301, DEBIAN-CVE-2018-1000301, DLA-1379-1, DSA-4202-1 and 5 more.

Is CVE-2018-1000301 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free