{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000400 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-1000400 is a high-severity vulnerability in n/a, published on 18 May 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000400 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000400 is a high-severity vulnerability in n/a, published on 18 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000400 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000400/ (Markdown: https://insights.sbomify.com/CVE-2018-1000400/index.md)","id":"CVE-2018-1000400","markdown":"https://insights.sbomify.com/CVE-2018-1000400/index.md","name":"CVE-2018-1000400","record":{"aliases":["GHSA-339v-9xv2-qg2w"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes CRI-O","requires_auth":"low_privilege","summary":"Attackers can execute containers with elevated privileges due to improper handling of ambient capabilities, bypassing intended security restrictions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cri-o","vendor":"kubernetes"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Kubernetes CRI-O version prior to 1.9 contains a Privilege Context Switching Error (CWE-270) vulnerability in the handling of ambient capabilities that can result in containers running with elevated privileges, allowing users abilities they should not have. This attack appears to be exploitable via container execution. This vulnerability appears to have been fixed in 1.9.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in n/a","id":"CVE-2018-1000400","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2018"},"n_packages":0,"n_references":2,"next":{"headline":"Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials","id":"CVE-2018-1000401"},"packages":[],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-1000301"},"products":["n/a"],"published":"2018-05-18","related":[{"cvss_score":8.8,"headline":"Code Injection in CRI-O","id":"CVE-2022-0811","kev_date_added":null,"published":"2022-03-16"},{"cvss_score":8.1,"headline":"Cri-o: malicious container can create symlink on host","id":"CVE-2024-5154","kev_date_added":null,"published":"2024-06-12"},{"cvss_score":7.1,"headline":"CRI-O incorrect handling of supplementary groups may lead to sensitive information disclosure","id":"CVE-2022-2995","kev_date_added":null,"published":"2022-09-19"},{"cvss_score":4.8,"headline":"Cri-o: security regression of cve-2022-27652","id":"CVE-2022-3466","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":4.2,"headline":"Incorrect Permission Assignment for Critical Resource in CRI-O","id":"CVE-2022-0532","kev_date_added":null,"published":"2022-02-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute containers with elevated privileges due to improper handling of ambient capabilities, bypassing intended security restrictions.","url":"https://insights.sbomify.com/CVE-2018-1000400/"}