# CVE-2018-1000400: Privilege escalation in n/a

> Attackers can execute containers with elevated privileges due to improper handling of ambient capabilities, bypassing intended security restrictions.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-339v-9xv2-qg2w

## What is CVE-2018-1000400?

CVE-2018-1000400 is a high-severity vulnerability in n/a, published on 18 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kubernetes CRI-O version prior to 1.9 contains a Privilege Context Switching Error (CWE-270) vulnerability in the handling of ambient capabilities that can result in containers running with elevated privileges, allowing users abilities they should not have. This attack appears to be exploitable via container execution. This vulnerability appears to have been fixed in 1.9.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2018-1000400?

It affects 1 product.


Products: Kubernetes Cri-O.

## How do I fix CVE-2018-1000400?

Upgrade to a fixed version.

## Is CVE-2018-1000400 being exploited?

There is no known exploitation of CVE-2018-1000400 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-0811](https://insights.sbomify.com/CVE-2022-0811/): Code Injection in CRI-O (high 8.8)
- [CVE-2024-5154](https://insights.sbomify.com/CVE-2024-5154/): Cri-o: malicious container can create symlink on host (high 8.1)
- [CVE-2022-2995](https://insights.sbomify.com/CVE-2022-2995/): CRI-O incorrect handling of supplementary groups may lead to sensitive information disclosure (high 7.1)
- [CVE-2022-3466](https://insights.sbomify.com/CVE-2022-3466/): Cri-o: security regression of cve-2022-27652 (medium 4.8)
- [CVE-2022-0532](https://insights.sbomify.com/CVE-2022-0532/): Incorrect Permission Assignment for Critical Resource in CRI-O (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000400 and fix it if it is affected.

What it is: CVE-2018-1000400 is a high-severity vulnerability in n/a, published on 18 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000400 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000400/ (Markdown: https://insights.sbomify.com/CVE-2018-1000400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000400
- OSV: https://osv.dev/vulnerability/CVE-2018-1000400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000400/
Summaries are generated and may contain mistakes; the official description above is the record.
