CVE-2018-1000401 Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials

High 7.8 Published Updated

An attacker with local file access can disclose AWS credentials stored by the Jenkins AWS CodePipeline Plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000401?

CVE-2018-1000401 is a high-severity vulnerability in n/a, published on 9 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.

Weakness: CWE-522

Which versions are affected by CVE-2018-1000401?

2 open source packages ship an affected version, including com.amazonaws:aws-codepipeline. It affects 1 product.

PackageAffectedFixed in
com.amazonaws:aws-codepipeline MavenAll versions0.37
com.amazonaws:aws-codepipeline MavenAll versions0.37

Products include Jenkins Aws Codepipeline.

How do I fix CVE-2018-1000401?

Upgrade com.amazonaws:aws-codepipeline to 0.37 or later.

Is CVE-2018-1000401 being exploited?

There is no known exploitation of CVE-2018-1000401 in the wild and no public exploit code.

Sources

Also known as GHSA-5gwq-4275-q4qc.

Is CVE-2018-1000401 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free