{"answers":{"affected":"2 open source packages ship an affected version, including com.amazonaws:aws-codepipeline. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000401 in the wild and no public exploit code.","fix":"Upgrade com.amazonaws:aws-codepipeline to 0.37 or later.","what":"CVE-2018-1000401 is a high-severity vulnerability in n/a, published on 9 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000401 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000401 is a high-severity vulnerability in n/a, published on 9 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000401 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.amazonaws:aws-codepipeline (Maven): affected all versions; fixed in 0.37\n- com.amazonaws:aws-codepipeline (Maven): affected all versions; fixed in 0.37\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000401/ (Markdown: https://insights.sbomify.com/CVE-2018-1000401/index.md)","id":"CVE-2018-1000401","markdown":"https://insights.sbomify.com/CVE-2018-1000401/index.md","name":"CVE-2018-1000401","record":{"aliases":["GHSA-5gwq-4275-q4qc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Jenkins AWS plugin","requires_auth":"low_privilege","summary":"An attacker with local file access can disclose AWS credentials stored by the Jenkins AWS CodePipeline Plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aws_codepipeline","vendor":"jenkins"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials","id":"CVE-2018-1000401","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials","id":"CVE-2018-1000402"},"packages":[{"ecosystem":"Maven","fixed":["0.37"],"introduced":["0"],"last_affected":[],"package":"com.amazonaws:aws-codepipeline","purl":null,"source":"GHSA-5gwq-4275-q4qc"},{"ecosystem":"Maven","fixed":["0.37"],"introduced":["0"],"last_affected":[],"package":"com.amazonaws:aws-codepipeline","purl":"pkg:maven/com.amazonaws/aws-codepipeline","source":"GHSA-5gwq-4275-q4qc"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2018-1000400"},"products":["n/a"],"published":"2018-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker with local file access can disclose AWS credentials stored by the Jenkins AWS CodePipeline Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000401/"}