CVE-2018-1000402 Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials

Medium 4.3 Published Updated

An attacker can disclose environment variables via the Jenkins AWS CodeDeploy Plugin, potentially exposing sensitive configuration data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000402?

CVE-2018-1000402 is a medium-severity vulnerability in n/a, published on 9 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later.

Weakness: CWE-200

Which versions are affected by CVE-2018-1000402?

2 open source packages ship an affected version, including com.amazonaws:codedeploy. It affects 1 product.

PackageAffectedFixed in
com.amazonaws:codedeploy MavenAll versions1.20
com.amazonaws:codedeploy MavenAll versions1.20

Products include Jenkins Aws Codedeploy.

How do I fix CVE-2018-1000402?

Upgrade com.amazonaws:codedeploy to 1.20 or later.

Is CVE-2018-1000402 being exploited?

There is no known exploitation of CVE-2018-1000402 in the wild and no public exploit code.

Sources

Also known as GHSA-644j-jcc4-crx7.

Is CVE-2018-1000402 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free