# CVE-2018-1000402: Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials

> An attacker can disclose environment variables via the Jenkins AWS CodeDeploy Plugin, potentially exposing sensitive configuration data.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-644j-jcc4-crx7

## What is CVE-2018-1000402?

CVE-2018-1000402 is a medium-severity vulnerability in n/a, published on 9 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1000402?

2 open source packages ship an affected version, including com.amazonaws:codedeploy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.amazonaws:codedeploy` | Maven | All versions | 1.20 |
| `com.amazonaws:codedeploy` | Maven | All versions | 1.20 |

Products: Jenkins Aws Codedeploy.

## How do I fix CVE-2018-1000402?

Upgrade com.amazonaws:codedeploy to 1.20 or later.

## Is CVE-2018-1000402 being exploited?

There is no known exploitation of CVE-2018-1000402 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000403](https://insights.sbomify.com/CVE-2018-1000403/): AWS CodeDeploy Plugin stored AWS Secret Key in plain text (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000402 and fix it if it is affected.

What it is: CVE-2018-1000402 is a medium-severity vulnerability in n/a, published on 9 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000402 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.amazonaws:codedeploy (Maven): affected all versions; fixed in 1.20
- com.amazonaws:codedeploy (Maven): affected all versions; fixed in 1.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000402/ (Markdown: https://insights.sbomify.com/CVE-2018-1000402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000402
- OSV: https://osv.dev/vulnerability/CVE-2018-1000402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000402/
Summaries are generated and may contain mistakes; the official description above is the record.
