{"answers":{"affected":"2 open source packages ship an affected version, including com.amazonaws:codedeploy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000403 in the wild and no public exploit code.","fix":"Upgrade com.amazonaws:codedeploy to 1.20 or later.","what":"CVE-2018-1000403 is a high-severity vulnerability in n/a, published on 9 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000403 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000403 is a high-severity vulnerability in n/a, published on 9 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000403 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.amazonaws:codedeploy (Maven): affected all versions; fixed in 1.20\n- com.amazonaws:codedeploy (Maven): affected all versions; fixed in 1.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000403/ (Markdown: https://insights.sbomify.com/CVE-2018-1000403/index.md)","id":"CVE-2018-1000403","markdown":"https://insights.sbomify.com/CVE-2018-1000403/index.md","name":"CVE-2018-1000403","record":{"aliases":["GHSA-h66p-m766-33fv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Jenkins AWS CodeDeploy Plugin","requires_auth":"low_privilege","summary":"An attacker with local file access can disclose AWS credentials stored by the Jenkins AWS CodeDeploy Plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aws_codedeploy","vendor":"jenkins"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 1.20 and later.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AWS CodeDeploy Plugin stored AWS Secret Key in plain text","id":"CVE-2018-1000403","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Insufficiently Protected Credentials in Jenkins AWS CodeBuild Plugin","id":"CVE-2018-1000404"},"packages":[{"ecosystem":"Maven","fixed":["1.20"],"introduced":["0"],"last_affected":[],"package":"com.amazonaws:codedeploy","purl":null,"source":"GHSA-h66p-m766-33fv"},{"ecosystem":"Maven","fixed":["1.20"],"introduced":["0"],"last_affected":[],"package":"com.amazonaws:codedeploy","purl":"pkg:maven/com.amazonaws/codedeploy","source":"GHSA-h66p-m766-33fv"}],"prev":{"headline":"Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials","id":"CVE-2018-1000402"},"products":["n/a"],"published":"2018-07-09","related":[{"cvss_score":4.3,"headline":"Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials","id":"CVE-2018-1000402","kev_date_added":null,"published":"2018-07-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker with local file access can disclose AWS credentials stored by the Jenkins AWS CodeDeploy Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000403/"}