CVE-2018-1000404 Insufficiently Protected Credentials in Jenkins AWS CodeBuild Plugin

High 7.8 Published Updated

An attacker with local file access can disclose AWS credentials stored by the Jenkins AWS CodeBuild Plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000404?

CVE-2018-1000404 is a high-severity vulnerability in n/a, published on 9 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Jenkins project Jenkins AWS CodeBuild Plugin version 0.26 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSClientFactory.java, CodeBuilder.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.27 and later.

Weakness: CWE-522

Which versions are affected by CVE-2018-1000404?

2 open source packages ship an affected version, including com.amazonaws:aws-codebuild. It affects 1 product.

PackageAffectedFixed in
com.amazonaws:aws-codebuild MavenAll versions0.27
com.amazonaws:aws-codebuild MavenAll versions0.27

Products include Jenkins Aws Codebuild.

How do I fix CVE-2018-1000404?

Upgrade com.amazonaws:aws-codebuild to 0.27 or later.

Is CVE-2018-1000404 being exploited?

There is no known exploitation of CVE-2018-1000404 in the wild and no public exploit code.

Sources

Also known as GHSA-mwg7-69hf-vqh3.

Is CVE-2018-1000404 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free