CVE-2018-1000407 Cross-site Scripting in Jenkins

Medium 6.1 Published Updated

Attackers can inject arbitrary HTML into Jenkins via crafted URLs, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-1000407?

CVE-2018-1000407 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A cross-site scripting vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and earlier in core/src/main/java/hudson/model/Api.java that allows attackers to specify URLs to Jenkins that result in rendering arbitrary attacker-controlled HTML by Jenkins.

Weakness: CWE-79

Which versions are affected by CVE-2018-1000407?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.138.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.138.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.1402.146
org.jenkins-ci.main:jenkins-core MavenFrom 2.1402.146

Products include Jenkins Jenkins.

How do I fix CVE-2018-1000407?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.138.2 or 2.146.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-1000407 being exploited?

There is no known exploitation of CVE-2018-1000407 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-hv45-5j9h-7fhg.

Is CVE-2018-1000407 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free