# CVE-2018-1000409: Session Fixation in Jenkins

> Attackers can hijack user sessions during account creation in Jenkins, potentially leading to unauthorized access to user accounts.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rr6r-p7rw-369c

## What is CVE-2018-1000409?

CVE-2018-1000409 is a medium-severity authentication bypass vulnerability in Jenkins Jenkins, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A session fixation vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and earlier in core/src/main/java/hudson/security/HudsonPrivateSecurityRealm.java that prevented Jenkins from invalidating the existing session and creating a new one when a user signed up for a new user account.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2018-1000409?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.138.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.138.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.140 | 2.146 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.140 | 2.146 |

Products: Jenkins Jenkins.

## How do I fix CVE-2018-1000409?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.138.2 or 2.146.

## Is CVE-2018-1000409 being exploited?

There is no known exploitation of CVE-2018-1000409 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000409 and fix it if it is affected.

What it is: CVE-2018-1000409 is a medium-severity authentication bypass vulnerability in Jenkins Jenkins, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000409 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.138.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.138.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.140; fixed in 2.146
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.140; fixed in 2.146

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000409/ (Markdown: https://insights.sbomify.com/CVE-2018-1000409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000409
- OSV: https://osv.dev/vulnerability/CVE-2018-1000409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000409/
Summaries are generated and may contain mistakes; the official description above is the record.
