CVE-2018-1000410 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

High 7.8 Published Updated

Attackers with admin permissions or local access can retrieve user credentials from failed form submissions in Jenkins.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000410?

CVE-2018-1000410 is a high-severity vulnerability in Jenkins Jenkins, published on 9 Jan 2019. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

An information exposure vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and earlier, and the Stapler framework used by these releases, in core/src/main/java/org/kohsuke/stapler/RequestImpl.java, core/src/main/java/hudson/model/Descriptor.java that allows attackers with Overall/Administer permission or access to the local file system to obtain credentials entered by users if the form submission could not be successfully processed.

Weakness: CWE-200

Which versions are affected by CVE-2018-1000410?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.138.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.138.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.1402.146
org.jenkins-ci.main:jenkins-core MavenFrom 2.1402.146

Products include Jenkins Jenkins.

How do I fix CVE-2018-1000410?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.138.2 or 2.146.

Is CVE-2018-1000410 being exploited?

There is no known exploitation of CVE-2018-1000410 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-53jp-gmwc-jwf6.

Is CVE-2018-1000410 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free