# CVE-2018-1000411: Jenkins JUnit Plugin CSRF vulnerability

> Attackers can force users to modify test result descriptions via CSRF, requiring plugin updates to mitigate.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x9gm-m8pp-54vx

## What is CVE-2018-1000411?

CVE-2018-1000411 is a medium-severity vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability exists in Jenkins JUnit Plugin 1.25 and earlier in TestObject.java that allows setting the description of a test result.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-1000411?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:junit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:junit` | Maven | All versions | 1.26 |
| `org.jenkins-ci.plugins:junit` | Maven | All versions | 1.26 |

Products: Jenkins Junit.

## How do I fix CVE-2018-1000411?

Upgrade org.jenkins-ci.plugins:junit to 1.26 or later.

## Is CVE-2018-1000411 being exploited?

There is no known exploitation of CVE-2018-1000411 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000056](https://insights.sbomify.com/CVE-2018-1000056/): Improper Restriction of XML External Entity Reference in Jenkins JUnit Plugin (high 8.3)
- [CVE-2023-25761](https://insights.sbomify.com/CVE-2023-25761/): Cross-site Scripting in Jenkins JUnit Plugin (medium 5.4)
- [CVE-2022-45380](https://insights.sbomify.com/CVE-2022-45380/): Jenkins JUnit Plugin subject to Cross-site Scripting via URL conversion (medium 5.4)
- [CVE-2022-34176](https://insights.sbomify.com/CVE-2022-34176/): Cross-site Scripting in Jenkins JUnit Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000411 and fix it if it is affected.

What it is: CVE-2018-1000411 is a medium-severity vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000411 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:junit (Maven): affected all versions; fixed in 1.26
- org.jenkins-ci.plugins:junit (Maven): affected all versions; fixed in 1.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000411/ (Markdown: https://insights.sbomify.com/CVE-2018-1000411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000411
- OSV: https://osv.dev/vulnerability/CVE-2018-1000411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000411/
Summaries are generated and may contain mistakes; the official description above is the record.
