{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:jobConfigHistory. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000416 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:jobConfigHistory to 2.18.1 or later.","what":"CVE-2018-1000416 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000416 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000416 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000416 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:jobConfigHistory (Maven): affected all versions; fixed in 2.18.1\n- org.jenkins-ci.plugins:jobConfigHistory (Maven): affected all versions; fixed in 2.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000416/ (Markdown: https://insights.sbomify.com/CVE-2018-1000416/index.md)","id":"CVE-2018-1000416","markdown":"https://insights.sbomify.com/CVE-2018-1000416/index.md","name":"CVE-2018-1000416","record":{"aliases":["GHSA-w3r4-vx9w-f7p7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"none","summary":"Reflected XSS in Jenkins Job Config History Plugin allows attackers to inject HTML, potentially leading to code execution or account takeover for users with configure access.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jobconfighistory","vendor":"jobconfighistory_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A reflected cross-site scripting vulnerability exists in Jenkins Job Config History Plugin 2.18 and earlier in all Jelly files that shows arbitrary attacker-specified HTML in Jenkins to users with Job/Configure access.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Job Config History Plugin reflected XSS vulnerability","id":"CVE-2018-1000416","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in Email Extension Template Plugin","id":"CVE-2018-1000417"},"packages":[{"ecosystem":"Maven","fixed":["2.18.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jobConfigHistory","purl":null,"source":"GHSA-w3r4-vx9w-f7p7"},{"ecosystem":"Maven","fixed":["2.18.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jobConfigHistory","purl":"pkg:maven/org.jenkins-ci.plugins/jobConfigHistory","source":"GHSA-w3r4-vx9w-f7p7"}],"prev":{"headline":"Cross-site Scripting in Jenkins Rebuilder Plugin","id":"CVE-2018-1000415"},"products":["n/a"],"published":"2019-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Reflected XSS in Jenkins Job Config History Plugin allows attackers to inject HTML, potentially leading to code execution or account takeover for users with configure access.","url":"https://insights.sbomify.com/CVE-2018-1000416/"}