# CVE-2018-1000416: Jenkins Job Config History Plugin reflected XSS vulnerability

> Reflected XSS in Jenkins Job Config History Plugin allows attackers to inject HTML, potentially leading to code execution or account takeover for users with configure access.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w3r4-vx9w-f7p7

## What is CVE-2018-1000416?

CVE-2018-1000416 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A reflected cross-site scripting vulnerability exists in Jenkins Job Config History Plugin 2.18 and earlier in all Jelly files that shows arbitrary attacker-specified HTML in Jenkins to users with Job/Configure access.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000416?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:jobConfigHistory. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:jobConfigHistory` | Maven | All versions | 2.18.1 |
| `org.jenkins-ci.plugins:jobConfigHistory` | Maven | All versions | 2.18.1 |

Products: Jobconfighistory Project Jobconfighistory.

## How do I fix CVE-2018-1000416?

Upgrade org.jenkins-ci.plugins:jobConfigHistory to 2.18.1 or later.

## Is CVE-2018-1000416 being exploited?

There is no known exploitation of CVE-2018-1000416 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000416 and fix it if it is affected.

What it is: CVE-2018-1000416 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000416 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:jobConfigHistory (Maven): affected all versions; fixed in 2.18.1
- org.jenkins-ci.plugins:jobConfigHistory (Maven): affected all versions; fixed in 2.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000416/ (Markdown: https://insights.sbomify.com/CVE-2018-1000416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000416
- OSV: https://osv.dev/vulnerability/CVE-2018-1000416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000416/
Summaries are generated and may contain mistakes; the official description above is the record.
