# CVE-2018-1000417: CSRF vulnerability in Email Extension Template Plugin

> Attackers can trick users into creating or removing email templates in Jenkins via cross-site request forgery.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4m38-gqh8-x266

## What is CVE-2018-1000417?

CVE-2018-1000417 is a high-severity vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability exists in Jenkins Email Extension Template Plugin 1.0 and earlier in ExtEmailTemplateManagement.java that allows creating or removing templates.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-1000417?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:email-ext. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:email-ext` | Maven | All versions | 1.1 |
| `org.jenkins-ci.plugins:email-ext` | Maven | All versions | 1.1 |

Products: Jenkins Email Extension Template.

## How do I fix CVE-2018-1000417?

Upgrade org.jenkins-ci.plugins:email-ext to 1.1 or later.

## Is CVE-2018-1000417 being exploited?

There is no known exploitation of CVE-2018-1000417 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000417 and fix it if it is affected.

What it is: CVE-2018-1000417 is a high-severity vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000417 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:email-ext (Maven): affected all versions; fixed in 1.1
- org.jenkins-ci.plugins:email-ext (Maven): affected all versions; fixed in 1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000417/ (Markdown: https://insights.sbomify.com/CVE-2018-1000417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000417
- OSV: https://osv.dev/vulnerability/CVE-2018-1000417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000417/
Summaries are generated and may contain mistakes; the official description above is the record.
