{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:hipchat. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000418 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:hipchat to 2.2.1 or later.","what":"CVE-2018-1000418 is a high-severity missing authorization vulnerability in n/a, published on 9 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000418 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000418 is a high-severity missing authorization vulnerability in n/a, published on 9 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000418 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:hipchat (Maven): affected all versions; fixed in 2.2.1\n- org.jvnet.hudson.plugins:hipchat (Maven): affected all versions; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000418/ (Markdown: https://insights.sbomify.com/CVE-2018-1000418/index.md)","id":"CVE-2018-1000418","markdown":"https://insights.sbomify.com/CVE-2018-1000418/index.md","name":"CVE-2018-1000418","record":{"aliases":["GHSA-w3f7-2qfw-348x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins HipChat Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can send test notifications to external servers, capturing stored Jenkins credentials due to improper authorization checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"hipchat","vendor":"atlassian"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers with Overall/Read access to send test notifications to an attacker-specified HipChat server with attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins HipChat Plugin allows credential capture due to incorrect authorization","id":"CVE-2018-1000418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins HipChat Plugin allows attackers with Overall/Read access to obtain credential IDs","id":"CVE-2018-1000419"},"packages":[{"ecosystem":"Maven","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:hipchat","purl":null,"source":"GHSA-w3f7-2qfw-348x"},{"ecosystem":"Maven","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:hipchat","purl":"pkg:maven/org.jvnet.hudson.plugins/hipchat","source":"GHSA-w3f7-2qfw-348x"}],"prev":{"headline":"CSRF vulnerability in Email Extension Template Plugin","id":"CVE-2018-1000417"},"products":["n/a"],"published":"2019-01-09","related":[{"cvss_score":9.8,"headline":"The Hipchat for Mac desktop client is vulnerable to client-side remote code execution via video call link parsing.","id":"CVE-2017-14586","kev_date_added":null,"published":"2017-11-27"},{"cvss_score":6.5,"headline":"Jenkins HipChat Plugin allows attackers with Overall/Read access to obtain credential IDs","id":"CVE-2018-1000419","kev_date_added":null,"published":"2019-01-09"},{"cvss_score":6.5,"headline":"Code injection in n/a","id":"CVE-2015-5603","kev_date_added":null,"published":"2015-09-21"},{"cvss_score":5.9,"headline":"Security feature bypass in n/a","id":"CVE-2017-8058","kev_date_added":null,"published":"2017-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers with read access can send test notifications to external servers, capturing stored Jenkins credentials due to improper authorization checks.","url":"https://insights.sbomify.com/CVE-2018-1000418/"}