# CVE-2018-1000418: Jenkins HipChat Plugin allows credential capture due to incorrect authorization

> Attackers with read access can send test notifications to external servers, capturing stored Jenkins credentials due to improper authorization checks.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w3f7-2qfw-348x

## What is CVE-2018-1000418?

CVE-2018-1000418 is a high-severity missing authorization vulnerability in n/a, published on 9 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers with Overall/Read access to send test notifications to an attacker-specified HipChat server with attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1000418?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:hipchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:hipchat` | Maven | All versions | 2.2.1 |
| `org.jvnet.hudson.plugins:hipchat` | Maven | All versions | 2.2.1 |

Products: Atlassian Hipchat.

## How do I fix CVE-2018-1000418?

Upgrade org.jvnet.hudson.plugins:hipchat to 2.2.1 or later.

## Is CVE-2018-1000418 being exploited?

There is no known exploitation of CVE-2018-1000418 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-14586](https://insights.sbomify.com/CVE-2017-14586/): The Hipchat for Mac desktop client is vulnerable to client-side remote code execution via video call link parsing. (critical 9.8)
- [CVE-2018-1000419](https://insights.sbomify.com/CVE-2018-1000419/): Jenkins HipChat Plugin allows attackers with Overall/Read access to obtain credential IDs (medium 6.5)
- [CVE-2015-5603](https://insights.sbomify.com/CVE-2015-5603/): Code injection in n/a (medium 6.5)
- [CVE-2017-8058](https://insights.sbomify.com/CVE-2017-8058/): Security feature bypass in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000418 and fix it if it is affected.

What it is: CVE-2018-1000418 is a high-severity missing authorization vulnerability in n/a, published on 9 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000418 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:hipchat (Maven): affected all versions; fixed in 2.2.1
- org.jvnet.hudson.plugins:hipchat (Maven): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000418/ (Markdown: https://insights.sbomify.com/CVE-2018-1000418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000418
- OSV: https://osv.dev/vulnerability/CVE-2018-1000418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000418/
Summaries are generated and may contain mistakes; the official description above is the record.
