{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:crowd2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000422 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:crowd2 to 2.0.1 or later.","what":"CVE-2018-1000422 is a medium-severity server-side request forgery vulnerability in n/a, published on 9 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000422 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000422 is a medium-severity server-side request forgery vulnerability in n/a, published on 9 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000422 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:crowd2 (Maven): affected all versions; fixed in 2.0.1\n- org.jenkins-ci.plugins:crowd2 (Maven): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000422/ (Markdown: https://insights.sbomify.com/CVE-2018-1000422/index.md)","id":"CVE-2018-1000422","markdown":"https://insights.sbomify.com/CVE-2018-1000422/index.md","name":"CVE-2018-1000422","record":{"aliases":["GHSA-grmg-5q49-mqmf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Crowd plugin","requires_auth":"low_privilege","summary":"Attackers can force Jenkins to connect to arbitrary servers with attacker-controlled credentials, enabling Server-Side Request Forgery and potential data exposure.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"crowd2","vendor":"atlassian"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Crowd 2 Integration Plugin server-side request forgery vulnerability","id":"CVE-2018-1000422","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Crowd 2 Integration Plugin stored credentials in plain text","id":"CVE-2018-1000423"},"packages":[{"ecosystem":"Maven","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:crowd2","purl":null,"source":"GHSA-grmg-5q49-mqmf"},{"ecosystem":"Maven","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:crowd2","purl":"pkg:maven/org.jenkins-ci.plugins/crowd2","source":"GHSA-grmg-5q49-mqmf"}],"prev":{"headline":"Server-side request forgery vulnerability in Jenkins Mesos Plugin","id":"CVE-2018-1000421"},"products":["n/a"],"published":"2019-01-09","related":[{"cvss_score":7.8,"headline":"Jenkins Crowd 2 Integration Plugin stored credentials in plain text","id":"CVE-2018-1000423","kev_date_added":null,"published":"2019-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can force Jenkins to connect to arbitrary servers with attacker-controlled credentials, enabling Server-Side Request Forgery and potential data exposure.","url":"https://insights.sbomify.com/CVE-2018-1000422/"}