# CVE-2018-1000424: Jenkins Artifactory Plugin stored old directly entered credentials unencrypted on disk

> Attackers with local file system access can obtain old credentials stored by the Jenkins Artifactory Plugin.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cvh8-9j4x-5v4j

## What is CVE-2018-1000424?

CVE-2018-1000424 is a high-severity vulnerability in Jfrog Artifactory, published on 9 Jan 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An insufficiently protected credentials vulnerability exists in Jenkins Artifactory Plugin 2.16.1 and earlier in ArtifactoryBuilder.java, CredentialsConfig.java that allows attackers with local file system access to obtain old credentials configured for the plugin before it integrated with Credentials Plugin.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2018-1000424?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:artifactory. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:artifactory` | Maven | All versions | 2.16.2 |
| `org.jenkins-ci.plugins:artifactory` | Maven | All versions | 2.16.2 |

Products: Jfrog Artifactory.

## How do I fix CVE-2018-1000424?

Upgrade org.jenkins-ci.plugins:artifactory to 2.16.2 or later.

## Is CVE-2018-1000424 being exploited?

There is no known exploitation of CVE-2018-1000424 in the wild and no public exploit code.

## Other vulnerabilities in Jfrog Artifactory

- [CVE-2026-82329](https://insights.sbomify.com/CVE-2026-82329/): JFrog Artifactory Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2026-42016](https://insights.sbomify.com/CVE-2026-42016/): JFrog Artifactory Incorrect Authorization (high 8.1, exploited in the wild)
- [CVE-2026-42018](https://insights.sbomify.com/CVE-2026-42018/): JFrog Artifactory Improper Authentication (high 7.5, exploited in the wild)
- [CVE-2026-66384](https://insights.sbomify.com/CVE-2026-66384/): JFrog Artifactory Improper Limitation of a Pathname to a Restricted Directory (medium 5.3, exploited in the wild)
- [CVE-2019-17444](https://insights.sbomify.com/CVE-2019-17444/): JFrog Artifactory does not enforce default admin password change (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000424 and fix it if it is affected.

What it is: CVE-2018-1000424 is a high-severity vulnerability in Jfrog Artifactory, published on 9 Jan 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000424 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:artifactory (Maven): affected all versions; fixed in 2.16.2
- org.jenkins-ci.plugins:artifactory (Maven): affected all versions; fixed in 2.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000424/ (Markdown: https://insights.sbomify.com/CVE-2018-1000424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000424
- OSV: https://osv.dev/vulnerability/CVE-2018-1000424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000424/
Summaries are generated and may contain mistakes; the official description above is the record.
