# CVE-2018-1000425: Jenkins SonarQube Scanner Plugin stored server authentication token in plain text

> Attackers with local file system access can obtain SonarQube credentials stored by the Jenkins plugin, leading to credential exposure.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3ccq-gccx-pm7j

## What is CVE-2018-1000425?

CVE-2018-1000425 is a high-severity vulnerability in n/a, published on 9 Jan 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An insufficiently protected credentials vulnerability exists in Jenkins SonarQube Scanner Plugin 2.8 and earlier in SonarInstallation.java that allows attackers with local file system access to obtain the credentials used to connect to SonarQube.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2018-1000425?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:sonar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:sonar` | Maven | All versions | 2.8.1 |
| `org.jenkins-ci.plugins:sonar` | Maven | All versions | 2.8.1 |

Products: Sonarsource Sonarqube Scanner.

## How do I fix CVE-2018-1000425?

Upgrade org.jenkins-ci.plugins:sonar to 2.8.1 or later.

## Is CVE-2018-1000425 being exploited?

There is no known exploitation of CVE-2018-1000425 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000425 and fix it if it is affected.

What it is: CVE-2018-1000425 is a high-severity vulnerability in n/a, published on 9 Jan 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000425 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:sonar (Maven): affected all versions; fixed in 2.8.1
- org.jenkins-ci.plugins:sonar (Maven): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000425/ (Markdown: https://insights.sbomify.com/CVE-2018-1000425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000425
- OSV: https://osv.dev/vulnerability/CVE-2018-1000425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000425/
Summaries are generated and may contain mistakes; the official description above is the record.
