{"answers":{"affected":"3 open source packages ship an affected version, including websockets. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000518 in the wild and no public exploit code.","fix":"Upgrade websockets to 5.0 or later.","what":"CVE-2018-1000518 is a high-severity denial of service vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000518 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000518 is a high-severity denial of service vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000518 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- websockets (PyPI): affected all versions; fixed in 5.0\n- websockets (PyPI): affected from 4.0; fixed in 5.0\n- websockets (PyPI): affected from 4.0; fixed in 5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000518/ (Markdown: https://insights.sbomify.com/CVE-2018-1000518/index.md)","id":"CVE-2018-1000518","markdown":"https://insights.sbomify.com/CVE-2018-1000518/index.md","name":"CVE-2018-1000518","record":{"aliases":["GHSA-6g87-ff9q-v847","PYSEC-2018-79","openSUSE-SU-2024:11280-1","openSUSE-SU-2024:14166-1","openSUSE-SU-2026:11240-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python websockets library","requires_auth":"none","summary":"Attackers can cause denial of service via memory exhaustion by sending crafted compressed frames to websockets servers or clients.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"websockets","vendor":"websockets_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"aaugustin websockets version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Servers and clients, unless configured with compression=None that can result in Denial of Service by memory exhaustion. This attack appear to be exploitable via Sending a specially crafted frame on an established connection. This vulnerability appears to have been fixed in 5.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"websockets is vulnerable to denial of service by memory exhaustion","id":"CVE-2018-1000518","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":6,"n_references":1,"next":{"headline":"aiohttp-session Session Fixation vulnerability","id":"CVE-2018-1000519"},"packages":[{"ecosystem":"PyPI","fixed":["5.0"],"introduced":["0"],"last_affected":[],"package":"websockets","purl":"pkg:pypi/websockets","source":"PYSEC-2018-79"},{"ecosystem":"PyPI","fixed":["5.0"],"introduced":["4.0"],"last_affected":[],"package":"websockets","purl":null,"source":"GHSA-6g87-ff9q-v847"},{"ecosystem":"PyPI","fixed":["5.0"],"introduced":["4.0"],"last_affected":[],"package":"websockets","purl":"pkg:pypi/websockets","source":"GHSA-6g87-ff9q-v847"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["12.0-2.6"],"introduced":["0"],"last_affected":[],"package":"python-websockets","purl":"pkg:rpm/opensuse/python-websockets\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14166-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["16.0-2.1"],"introduced":["0"],"last_affected":[],"package":"python-websockets","purl":"pkg:rpm/opensuse/python-websockets\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11240-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["9.1-2.1"],"introduced":["0"],"last_affected":[],"package":"python-websockets","purl":"pkg:rpm/opensuse/python-websockets\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11280-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-1000517"},"products":["n/a"],"published":"2018-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause denial of service via memory exhaustion by sending crafted compressed frames to websockets servers or clients.","url":"https://insights.sbomify.com/CVE-2018-1000518/"}