CVE-2018-1000524 Integer overflow in n/a
An integer overflow in miniSphere allows remote attackers to cause a denial of service by tricking users into loading a specially crafted map file.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2018-1000524?
CVE-2018-1000524 is a medium-severity vulnerability in n/a, published on 26 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of service. This attack appear to be exploitable via the victim must load a specially-crafted map which calls SetLayerSize in its entry script. This vulnerability appears to have been fixed in 5.0.3, 5.1.5, 5.2.10 and later.
Weakness: CWE-190
Which versions are affected by CVE-2018-1000524?
It affects 1 product.
Products include Spheredev Minisphere.
How do I fix CVE-2018-1000524?
No fix has been published for CVE-2018-1000524 yet. Limit exposure of the affected software until one is available.
Is CVE-2018-1000524 being exploited?
There is no known exploitation of CVE-2018-1000524 in the wild and no public exploit code.
Sources
Also known as GHSA-q6fm-w33x-rj4m.