{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000524 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-1000524 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-1000524 is a medium-severity vulnerability in n/a, published on 26 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000524 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000524 is a medium-severity vulnerability in n/a, published on 26 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000524 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000524/ (Markdown: https://insights.sbomify.com/CVE-2018-1000524/index.md)","id":"CVE-2018-1000524","markdown":"https://insights.sbomify.com/CVE-2018-1000524/index.md","name":"CVE-2018-1000524","record":{"aliases":["GHSA-q6fm-w33x-rj4m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"miniSphere game engine","requires_auth":"none","summary":"An integer overflow in miniSphere allows remote attackers to cause a denial of service by tricking users into loading a specially crafted map file.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"minisphere","vendor":"spheredev"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of service. This attack appear to be exploitable via the victim must load a specially-crafted map which calls SetLayerSize in its entry script. This vulnerability appears to have been fixed in 5.0.3, 5.1.5, 5.2.10 and later.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Integer overflow in n/a","id":"CVE-2018-1000524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2018"},"n_packages":0,"n_references":2,"next":{"headline":"Deserialization in n/a","id":"CVE-2018-1000525"},"packages":[],"prev":{"headline":"Topydo Improper Input Validation vulnerability","id":"CVE-2018-1000523"},"products":["n/a"],"published":"2018-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An integer overflow in miniSphere allows remote attackers to cause a denial of service by tricking users into loading a specially crafted map file.","url":"https://insights.sbomify.com/CVE-2018-1000524/"}