CVE-2018-1000527 Froxlor PHP Object Injection vulnerability

High 7.2 Published Updated

Attacker can achieve remote code execution and information disclosure via PHP object injection in the domain name form.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000527?

CVE-2018-1000527 is a high-severity unsafe deserialization vulnerability in n/a, published on 26 Jun 2018. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Froxlor version <= 0.9.39.5 contains a PHP Object Injection vulnerability in Domain name form that can result in Possible information disclosure and remote code execution. This attack appear to be exploitable via Passing malicious PHP objection in $_POST['ssl_ipandport']. This vulnerability appears to have been fixed in after commit c1e62e6.

Weakness: CWE-502

Which versions are affected by CVE-2018-1000527?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.

PackageAffectedFixed in
froxlor/froxlor PackagistAll versions0.9.40
froxlor/froxlor PackagistAll versions0.9.40

Products include Froxlor Froxlor.

How do I fix CVE-2018-1000527?

Upgrade froxlor/froxlor to 0.9.40 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2018-1000527 being exploited?

There is no known exploitation of CVE-2018-1000527 in the wild and no public exploit code.

Sources

Also known as GHSA-g77v-m226-3f7g.

Is CVE-2018-1000527 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free