CVE-2018-1000529 Stored Cross Site Scripting in Grails Fields Plugin
An XSS vulnerability in the Grails Fields plugin allows attackers to inject malicious scripts via the display tag, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1000529?
CVE-2018-1000529 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.
Weakness: CWE-79
Which versions are affected by CVE-2018-1000529?
4 open source packages ship an affected version, including org.grails.plugins:fields and org.grails:grails-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.grails.plugins:fields Maven | All versions | 2.2.8 |
org.grails.plugins:fields Maven | All versions | 2.2.8 |
org.grails:grails-core Maven | All versions | 3.3.6 |
org.grails:grails-core Maven | All versions | 3.3.6 |
Products include Grails Grails Fields.
How do I fix CVE-2018-1000529?
Upgrade org.grails.plugins:fields to 2.2.8 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1000529 being exploited?
There is no known exploitation of CVE-2018-1000529 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-q25j-gcmv-5qpp.