{"answers":{"affected":"4 open source packages ship an affected version, including org.grails.plugins:fields and org.grails:grails-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000529 in the wild and no public exploit code.","fix":"Upgrade org.grails.plugins:fields to 2.2.8 or later.","what":"CVE-2018-1000529 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000529 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000529 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000529 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.grails.plugins:fields (Maven): affected all versions; fixed in 2.2.8\n- org.grails.plugins:fields (Maven): affected all versions; fixed in 2.2.8\n- org.grails:grails-core (Maven): affected all versions; fixed in 3.3.6\n- org.grails:grails-core (Maven): affected all versions; fixed in 3.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000529/ (Markdown: https://insights.sbomify.com/CVE-2018-1000529/index.md)","id":"CVE-2018-1000529","markdown":"https://insights.sbomify.com/CVE-2018-1000529/index.md","name":"CVE-2018-1000529","record":{"aliases":["GHSA-q25j-gcmv-5qpp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grails Fields plugin","requires_auth":"none","summary":"An XSS vulnerability in the Grails Fields plugin allows attackers to inject malicious scripts via the display tag, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"grails_fields","vendor":"grails"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2018-05-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-05-21T23:43:18Z","kind":"github_poc","ref":"https://github.com/martinfrancois/CVE-2018-1000529","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Stored Cross Site Scripting in Grails Fields Plugin","id":"CVE-2018-1000529","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":4,"n_references":2,"next":{"headline":"Auth bypass in n/a","id":"CVE-2018-1000531"},"packages":[{"ecosystem":"Maven","fixed":["2.2.8"],"introduced":["0"],"last_affected":[],"package":"org.grails.plugins:fields","purl":null,"source":"GHSA-q25j-gcmv-5qpp"},{"ecosystem":"Maven","fixed":["2.2.8"],"introduced":["0"],"last_affected":[],"package":"org.grails.plugins:fields","purl":"pkg:maven/org.grails.plugins/fields","source":"GHSA-q25j-gcmv-5qpp"},{"ecosystem":"Maven","fixed":["3.3.6"],"introduced":["0"],"last_affected":[],"package":"org.grails:grails-core","purl":null,"source":"GHSA-q25j-gcmv-5qpp"},{"ecosystem":"Maven","fixed":["3.3.6"],"introduced":["0"],"last_affected":[],"package":"org.grails:grails-core","purl":"pkg:maven/org.grails/grails-core","source":"GHSA-q25j-gcmv-5qpp"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000528"},"products":["n/a"],"published":"2018-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An XSS vulnerability in the Grails Fields plugin allows attackers to inject malicious scripts via the display tag, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2018-1000529/"}