# CVE-2018-1000533: Command injection in n/a

> Attackers can execute arbitrary code as the PHP user by sending a crafted POST request to the search form in GitList.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-24jr-8pxp-69pm

## What is CVE-2018-1000533?

CVE-2018-1000533 is a critical command injection vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

klaussilveira GitList version <= 0.6 contains a Passing incorrectly sanitized input to system function vulnerability in `searchTree` function that can result in Execute any code as PHP user. This attack appear to be exploitable via Send POST request using search form. This vulnerability appears to have been fixed in 0.7 after commit 87b8c26b023c3fc37f0796b14bb13710f397b322.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-1000533?

It affects 1 product.


Products: Gitlist Gitlist.

## How do I fix CVE-2018-1000533?

No fix has been published for CVE-2018-1000533 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-1000533 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000533 exists.

Public exploit code:

- GitList v0.6.0 Argument Injection Vulnerability (metasploit)
- https://github.com/dddo0/CVE-2018-1000533 (github_poc): https://github.com/dddo0/CVE-2018-1000533
- GitList < 0.6.0 Remote Code Execution (nuclei): http/cves/2018/CVE-2018-1000533.yaml

## Other vulnerabilities in n/a

- [CVE-2013-7392](https://insights.sbomify.com/CVE-2013-7392/): Command injection in n/a (high 7.5)
- [CVE-2014-4511](https://insights.sbomify.com/CVE-2014-4511/): Command injection in n/a (high 7.5)
- [CVE-2014-5023](https://insights.sbomify.com/CVE-2014-5023/): Command injection in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000533 and fix it if it is affected.

What it is: CVE-2018-1000533 is a critical command injection vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000533 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000533/ (Markdown: https://insights.sbomify.com/CVE-2018-1000533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000533
- OSV: https://osv.dev/vulnerability/CVE-2018-1000533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000533/
Summaries are generated and may contain mistakes; the official description above is the record.
