# CVE-2018-1000534: Joplin Vulnerable to Cross-site Scripting in Note Content

> Attackers can execute arbitrary code via XSS in note content when victims sync malicious notes, due to enabled nodeIntegration.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m6mf-hmrh-ph4j

## What is CVE-2018-1000534?

CVE-2018-1000534 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Joplin version prior to 1.0.90 contains a XSS evolving into code execution due to enabled nodeIntegration for that particular BrowserWindow instance where XSS was identified from vulnerability in Note content field - information on the fix can be found here https://github.com/laurent22/joplin/commit/494e235e18659574f836f84fcf9f4d4fcdcfcf89 that can result in executing unauthorized code within the rights in which the application is running. This attack appear to be exploitable via Victim synchronizing notes from the cloud services or other note-keeping services which contain malicious code. This vulnerability appears to have been fixed in 1.0.90 and later.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000534?

2 open source packages ship an affected version, including joplin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joplin` | npm | All versions | 1.0.90 |
| `joplin` | npm | All versions | 1.0.90 |

Products: Joplin Project Joplin.

## How do I fix CVE-2018-1000534?

Upgrade joplin to 1.0.90 or later.

## Is CVE-2018-1000534 being exploited?

There is no known exploitation of CVE-2018-1000534 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-23340](https://insights.sbomify.com/CVE-2022-23340/): Joplin Vulnerable to Code Injection (critical 9.8)
- [CVE-2024-40643](https://insights.sbomify.com/CVE-2024-40643/): Joplin has a parsing error leading to Cross-site Scripting (XSS) (critical 9.7)
- [CVE-2023-45673](https://insights.sbomify.com/CVE-2023-45673/): Arbitrary code execution on click of PDF links in Joplin (high 8.9)
- [CVE-2025-27134](https://insights.sbomify.com/CVE-2025-27134/): Privilege escalation in Joplin server via user patch endpoint (high 8.8)
- [CVE-2023-37898](https://insights.sbomify.com/CVE-2023-37898/): Safe mode Cross-site Scripting (XSS) vulnerability in Joplin (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000534 and fix it if it is affected.

What it is: CVE-2018-1000534 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000534 in the wild and no public exploit code.

Affected packages and fixed versions:
- joplin (npm): affected all versions; fixed in 1.0.90
- joplin (npm): affected all versions; fixed in 1.0.90

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000534/ (Markdown: https://insights.sbomify.com/CVE-2018-1000534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000534
- OSV: https://osv.dev/vulnerability/CVE-2018-1000534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000534/
Summaries are generated and may contain mistakes; the official description above is the record.
