{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000537 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-1000537 is a critical memory corruption vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000537 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000537 is a critical memory corruption vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000537 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000537/ (Markdown: https://insights.sbomify.com/CVE-2018-1000537/index.md)","id":"CVE-2018-1000537","markdown":"https://insights.sbomify.com/CVE-2018-1000537/index.md","name":"CVE-2018-1000537","record":{"aliases":["GHSA-52mm-j9gg-2xgp","openSUSE-SU-2024:11487-1"],"analysis":{"component_type":"hardware_firmware","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"3D printer firmware","requires_auth":"none","summary":"Attackers can execute arbitrary code on 3D printers by sending crafted G-Code files due to a buffer overflow in the card reader.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"marlin_firmware","vendor":"marlinfw"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Marlin Firmware Marlin version 1.1.x and earlier contains a Buffer Overflow vulnerability in cardreader.cpp (Depending on branch/version) that can result in Arbitrary code execution. This attack appear to be exploitable via Crafted G-Code instruction/file is sent to the printer.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2018-1000537","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2018"},"n_packages":1,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-1000538"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.1.9.34_5f9c029d1-1.9"],"introduced":["0"],"last_affected":[],"package":"uranium-firmware-lulzbot","purl":"pkg:rpm/opensuse/uranium-firmware-lulzbot\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11487-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000536"},"products":["n/a"],"published":"2018-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code on 3D printers by sending crafted G-Code files due to a buffer overflow in the card reader.","url":"https://insights.sbomify.com/CVE-2018-1000537/"}