# CVE-2018-1000539: Json-jwt did not verify the cryptographic signature for data

> Attackers can forge authentication tags in AES-GCM encrypted JSON Web Tokens, bypassing signature verification in the json-jwt Ruby library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2018-3768, DEBIAN-CVE-2018-1000539, DSA-4283-1, GHSA-mj4x-wcxf-hm8x, UBUNTU-CVE-2018-1000539

## What is CVE-2018-1000539?

CVE-2018-1000539 is a medium-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nov json-jwt version >= 0.5.0 && < 1.9.4 contains a CWE-347: Improper Verification of Cryptographic Signature vulnerability in Decryption of AES-GCM encrypted JSON Web Tokens that can result in Attacker can forge a authentication tag. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 1.9.4 and later.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2018-1000539?

2 open source packages ship an affected version, including json-jwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `json-jwt` | RubyGems | From 0.5.1 | 1.9.4 |
| `json-jwt` | RubyGems | From 0.5.1 | 1.9.4 |

Products: Json-Jwt Project Json-Jwt.

## How do I fix CVE-2018-1000539?

Upgrade json-jwt to 1.9.4 or later.

## Is CVE-2018-1000539 being exploited?

There is no known exploitation of CVE-2018-1000539 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-51774](https://insights.sbomify.com/CVE-2023-51774/): json-jwt allows bypass of identity checks via a sign/encryption confusion attack (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000539 and fix it if it is affected.

What it is: CVE-2018-1000539 is a medium-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000539 in the wild and no public exploit code.

Affected packages and fixed versions:
- json-jwt (RubyGems): affected from 0.5.1; fixed in 1.9.4
- json-jwt (RubyGems): affected from 0.5.1; fixed in 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000539/ (Markdown: https://insights.sbomify.com/CVE-2018-1000539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000539
- OSV: https://osv.dev/vulnerability/CVE-2018-1000539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000539/
Summaries are generated and may contain mistakes; the official description above is the record.
