# CVE-2018-1000544: Rubyzip gem contains a Directory Traversal vulnerability in zip file component

> Attackers can write arbitrary files to the filesystem via malicious zip uploads, impacting applications using the rubyzip gem.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000544, DLA-1467-1, DLA-2307-1, GHSA-vqcq-mrmw-mcmg, RHSA-2018:3466, UBUNTU-CVE-2018-1000544

## What is CVE-2018-1000544?

CVE-2018-1000544 is a critical path traversal vulnerability in Debian Debian Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem. This attack appear to be exploitable via If a site allows uploading of .zip files , an attacker can upload a malicious file that contains symlinks or files with absolute pathnames "../" to write arbitrary files to the filesystem..

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2018-1000544?

2 open source packages ship an affected version, including rubyzip. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubyzip` | RubyGems | All versions | 1.2.2 |
| `rubyzip` | RubyGems | All versions | 1.2.2 |
| `ansible-tower` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.7-1.el7at |
| `ansible-tower-server` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.7-1.el7at |
| `ansible-tower-setup` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.7-1.el7at |
| `ansible-tower-ui` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.7-1.el7at |
| `ansible-tower-venv-ansible` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.7-1.el7at |
| `ansible-tower-venv-tower` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.7-1.el7at |
| `cfme` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-amazon-smartstate` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-appliance` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-appliance-common` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-appliance-debuginfo` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-appliance-tools` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-debuginfo` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-gemset` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |
| `cfme-gemset-debuginfo` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.5.3-1.el7cf |

Products: Debian Debian Linux, Redhat Cloudforms, Rubyzip Project Rubyzip.

## How do I fix CVE-2018-1000544?

Upgrade rubyzip to 1.2.2 or later.

## Is CVE-2018-1000544 being exploited?

There is no known exploitation of CVE-2018-1000544 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000544 and fix it if it is affected.

What it is: CVE-2018-1000544 is a critical path traversal vulnerability in Debian Debian Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000544 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubyzip (RubyGems): affected all versions; fixed in 1.2.2
- rubyzip (RubyGems): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000544/ (Markdown: https://insights.sbomify.com/CVE-2018-1000544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000544
- OSV: https://osv.dev/vulnerability/CVE-2018-1000544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000544/
Summaries are generated and may contain mistakes; the official description above is the record.
