CVE-2018-1000559 Qutebrowser XSS Vulnerability

Medium 6.1 Published Updated

An attacker can steal browsing history via XSS in the history page when a user visits a crafted page and opens the history view.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-1000559?

CVE-2018-1000559 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

qutebrowser version introduced in v0.11.0 (1179ee7a937fb31414d77d9970bac21095358449) contains a Cross Site Scripting (XSS) vulnerability in history command, qute://history page that can result in Via injected JavaScript code, a website can steal the user's browsing history. This attack appear to be exploitable via the victim must open a page with a specially crafted <title> attribute, and then open the qute://history site via the :history command. This vulnerability appears to have been fixed in fixed in v1.3.3 (4c9360237f186681b1e3f2a0f30c45161cf405c7, to be released today) and v1.4.0 (5a7869f2feaa346853d2a85413d6527c87ef0d9f, released later this week).

Weakness: CWE-79

Which versions are affected by CVE-2018-1000559?

3 open source packages ship an affected version, including qutebrowser. It affects 1 product.

PackageAffectedFixed in
qutebrowser PyPIFrom 0.11.01.3.3
qutebrowser PyPIFrom 0.11.01.3.3
qutebrowser PyPIFrom 0.11.01.3.3

Products include Qutebrowser Qutebrowser.

How do I fix CVE-2018-1000559?

Upgrade qutebrowser to 1.3.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-1000559 being exploited?

There is no known exploitation of CVE-2018-1000559 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2018-1000559, GHSA-m4fw-77v7-924m, PYSEC-2018-26, UBUNTU-CVE-2018-1000559.

Is CVE-2018-1000559 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free