{"answers":{"affected":"3 open source packages ship an affected version, including qutebrowser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000559 in the wild and no public exploit code.","fix":"Upgrade qutebrowser to 1.3.3 or later.","what":"CVE-2018-1000559 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000559 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000559 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000559 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- qutebrowser (PyPI): affected from 0.11.0; fixed in 1.3.3\n- qutebrowser (PyPI): affected from 0.11.0; fixed in 1.3.3\n- qutebrowser (PyPI): affected from 0.11.0; fixed in 1.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000559/ (Markdown: https://insights.sbomify.com/CVE-2018-1000559/index.md)","id":"CVE-2018-1000559","markdown":"https://insights.sbomify.com/CVE-2018-1000559/index.md","name":"CVE-2018-1000559","record":{"aliases":["DEBIAN-CVE-2018-1000559","GHSA-m4fw-77v7-924m","PYSEC-2018-26","UBUNTU-CVE-2018-1000559"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"qutebrowser","requires_auth":"none","summary":"An attacker can steal browsing history via XSS in the history page when a user visits a crafted page and opens the history view.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"qutebrowser","vendor":"qutebrowser"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"qutebrowser version introduced in v0.11.0 (1179ee7a937fb31414d77d9970bac21095358449) contains a Cross Site Scripting (XSS) vulnerability in history command, qute://history page that can result in Via injected JavaScript code, a website can steal the user's browsing history. This attack appear to be exploitable via the victim must open a page with a specially crafted \u003ctitle\u003e attribute, and then open the qute://history site via the :history command. This vulnerability appears to have been fixed in fixed in v1.3.3 (4c9360237f186681b1e3f2a0f30c45161cf405c7, to be released today) and v1.4.0 (5a7869f2feaa346853d2a85413d6527c87ef0d9f, released later this week).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Qutebrowser XSS Vulnerability","id":"CVE-2018-1000559","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials","id":"CVE-2018-1000600"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.3"],"introduced":["0.11.0"],"last_affected":[],"package":"qutebrowser","purl":null,"source":"GHSA-m4fw-77v7-924m"},{"ecosystem":"PyPI","fixed":["1.3.3"],"introduced":["0.11.0"],"last_affected":[],"package":"qutebrowser","purl":"pkg:pypi/qutebrowser","source":"GHSA-m4fw-77v7-924m"},{"ecosystem":"PyPI","fixed":["1.3.3"],"introduced":["0.11.0"],"last_affected":[],"package":"qutebrowser","purl":"pkg:pypi/qutebrowser","source":"PYSEC-2018-26"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2018-1000558"},"products":["n/a"],"published":"2018-06-26","related":[{"cvss_score":9.3,"headline":"Qutebrowser CSRF Vulnerability","id":"CVE-2018-10895","kev_date_added":null,"published":"2018-07-12"},{"cvss_score":8.8,"headline":"Arbitrary command execution on Windows in qutebrowser","id":"CVE-2021-41146","kev_date_added":null,"published":"2021-10-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can steal browsing history via XSS in the history page when a user visits a crafted page and opens the history view.","url":"https://insights.sbomify.com/CVE-2018-1000559/"}