{"answers":{"affected":"2 open source packages ship an affected version, including com.coravy.hudson.plugins.github:github. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000600 exists.","fix":"Upgrade com.coravy.hudson.plugins.github:github to 1.29.2 or later.","what":"CVE-2018-1000600 is a high-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000600 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000600 is a high-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000600 exists.\n\nAffected packages and fixed versions:\n- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.2\n- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000600/ (Markdown: https://insights.sbomify.com/CVE-2018-1000600/index.md)","id":"CVE-2018-1000600","markdown":"https://insights.sbomify.com/CVE-2018-1000600/index.md","name":"CVE-2018-1000600","record":{"aliases":["GHSA-6cvm-v6qj-hjq9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins GitHub Plugin","requires_auth":"none","summary":"Attackers can capture Jenkins-stored credentials by directing the plugin to an attacker-controlled URL using specific credential IDs.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"github","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A exposure of sensitive information vulnerability exists in Jenkins GitHub Plugin 1.29.1 and earlier in GitHubTokenCredentialsCreator.java that allows attackers to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2018/CVE-2018-1000600.yaml","stars":null,"title":"Jenkins GitHub Plugin \u003c=1.29.1 - Server-Side Request Forgery"}],"tier":"weaponised"},"has_fix":true,"headline":"CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials","id":"CVE-2018-1000600","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Jenkins SSH Credentials Plugin","id":"CVE-2018-1000601"},"packages":[{"ecosystem":"Maven","fixed":["1.29.2"],"introduced":["0"],"last_affected":[],"package":"com.coravy.hudson.plugins.github:github","purl":null,"source":"GHSA-6cvm-v6qj-hjq9"},{"ecosystem":"Maven","fixed":["1.29.2"],"introduced":["0"],"last_affected":[],"package":"com.coravy.hudson.plugins.github:github","purl":"pkg:maven/com.coravy.hudson.plugins.github/github","source":"GHSA-6cvm-v6qj-hjq9"}],"prev":{"headline":"Qutebrowser XSS Vulnerability","id":"CVE-2018-1000559"},"products":["n/a"],"published":"2018-06-26","related":[{"cvss_score":9,"headline":"Jenkins GitHub Plugin has an XSS vulnerability","id":"CVE-2026-42523","kev_date_added":null,"published":"2026-04-29"},{"cvss_score":6.5,"headline":"Jenkins GitHub Plugin exposure of sensitive information vulnerability exists","id":"CVE-2018-1000183","kev_date_added":null,"published":"2018-06-05"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Jenkins GitHub Plugin","id":"CVE-2023-46650","kev_date_added":null,"published":"2023-10-25"},{"cvss_score":5.4,"headline":"Jenkins GitHub Plugin server-side request forgery vulnerability exists","id":"CVE-2018-1000184","kev_date_added":null,"published":"2018-06-05"},{"cvss_score":5.3,"headline":"Jenkins GitHub plugin uses weak webhook signature function","id":"CVE-2022-36885","kev_date_added":null,"published":"2022-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can capture Jenkins-stored credentials by directing the plugin to an attacker-controlled URL using specific credential IDs.","url":"https://insights.sbomify.com/CVE-2018-1000600/"}